Hot Rod Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
10,928 Posts
Discussion Starter · #1 · (Edited)
Well I was going to try and post a picture with this post, but I am not having much luck. Looked at the tip and tricks section on posting a picture, but I must be a little dense cause I cannot get it to work per the instructions. the picture is in my gallery and I can't seem to get the address right.

At any rate here is the story: Wife's 97 Tahoe has around 140,000 on the clock. We recently purchased an new 04 Tahoe so we are trying the sell the 97. It has developed a small oil leak I am repairing. The left valve cover gasket is leaking. Since I have been running Mobil 1 and Mobil 1 filters in the 97 Tahoe since about 20K miles I figured this would be an opportunity to see how clean the engine is. After removing the necessary components to gain access to the valve cover I removed it. The inside of the Vortec 350 is amazingly clean, no sludge, no build up of any sort. The Tahoe uses no oil and runs as good as the day we bought it. Mobil 1 works as well far as I am concerned. Now if I could just post a picture with this so I could show you:confused:

Vince
 

·
Premium Member
Joined
·
6,623 Posts
Synthetic oil rules, it's all I use. After seeing hundreds of aircraft engines come apart clean as a whistle when run with synthetic I became a believer. Some of the engines I had seen were absolutely atrocious inside, sludge tanks plugged solid on most of the Radial Pratt @ Witney's I seen if they were run on dinosaur oil.

My SHO with 160 000 Kms looks like new inside just like yours 302/Z28 and Larry.
 

·
Registered
Joined
·
10,928 Posts
Discussion Starter · #6 ·
Thanks Larry, now splain how you posted that pic for me:)

Vince

TurboS10 said:
Very nice. Is that the Mobil 1 Synthetic?
Yep, 5W-30W and Mobil 1 spun synthetic filters. IMO is makes little sense to run synthetic oil and cheap out on the filters.

Vince
 

·
Registered
Joined
·
290 Posts
Mobil 1

We have been using Mobil 1 synthetic 5w-30 in everything we own. About 6 months ago we sold our 95 GMC Suburban with 212,765 on the mileage. The people who bought it have put another 20+ on it but they are using Mobil 1 also. It had Mobil 1 since it was new. Our 02 Vette requires it's use and we run it in our 99 Tahoe. Every vehicle we have restored that's what we use. I've been using GM oil filters. Mobil1 is worth the $5.00 a quart rather than engine repairs at 100,000 miles.
 

·
Registered
Joined
·
5,653 Posts
302/Z28 said:
Thanks Larry, now splain how you posted that pic for me:)

Vince




:D :D


Vince..........I am not Larry but it is very easy.....

The photo was already being hosted so.........

Go to the photo you want to use ( that is already on the net)....click on it and make sure it is full size, THEN...you right click on it with the mouse. ...when the box pops up......right click on select all..then right click on the address.......then click ok......the photo is loaded. Then put it in the IMG slot after you click on it.......and paste it........

Done deal........


I use Mobile 1 also, My 96 Silverado had 160,000 miles with no problems and was as clean as yours..........

My ZZ430 came with it from GM.

Randy ...aka DEUCE

.

:D


Nice shop you have.........




DEUCE

:thumbup:
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top