Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok so I hook up my new Demon carb today everything running is great. I have an electric choke on the carb so decided to hook it up. It says you need a switched/12v power source and a ground. So I splice it into the switched 12/v source for the MSD (6A2) box because it is also a swtich 12/v. Run it down the road and seem fine. I park it and try to shut it off.....won't shut off. Like the Coil is getting a constant 12/v. Choke the car out to shut it off.

Start to trouble shoot this so I unhook the Electric choke and hook the MSD back up exactly like it was before....nothing happens no power to the coil. Hook it up to a constant 12/v and the car starts but won't shut off. I'm stumped! I know I should try finding another switched 12/v power source but the source I was using has power going to it...what gives? Why won't it start when hooked up to a switched source?
 

·
Registered
Joined
·
1,129 Posts
Msd Issue

Hey Man, Did you get it figured out yet? Sounds like you maybe have some wires crossed up. I don't know what kind of car you're working on but a 6al setup is pretty easy to hook up. The big red and the big black wires should be fed direct from the battery. The smaller red wire goes to a switched ignition 12v(from the key). The orange and black wires go to the coil. Don't tie any other wires into the coil circuit as they are high voltage from the MSD box. If you connected the choke to the same small red wire that turns on the MSD box, the MSD box might not like the extra load from the electric choke coil. I'm not sure if it matters though. It seems like you have your constant and switched circuits crossed up? olnolan
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top