Hot Rod Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
3,519 Posts
Discussion Starter #1
Here are my pics. I got a little freaked out when I saw it but 1BAD told me I'm fine. Saw the oil catcher and now I'm a little bit freaked out again. Tell me whatcha all think.











I think I'm gonna be aiiight... starting to calm down (miller time.)

K:thumbup:
 

·
Registered
Joined
·
169 Posts
I'm not exactly sure what I'm supposed to be seeing here. It looks like some Ultra blue RTV trapped in the upper pics and some journal sparkles in the lower pics. The filter element looks pretty black though, It wasn't born that way was it?
 

·
Premium Member
Joined
·
3,519 Posts
Discussion Starter #3
dunno if it was or not, oil was pretty clear, like almost new looking. Might have gotten a little darker, I've driven it twice since the new holley carb is on it... lol, wet flowed my butt. Thing is about 45 sizes too big on everything!

K
 

·
Registered
Joined
·
169 Posts
Some of the engines I've built had goodies trapped in the filter for about 15000 kms after the build. I've seen a couple of engine builders that glass block sand a whole whack of stuff (thrust bearings, sides of rods, sides of caps, etc,) before they assemble. I was told parts fit a little better that way and you get less goodies during break in. Every thing has to wear against it's adjoining partner so it will run smooth, I wouldn't worry too much about it unless there's actual shavings or the engine sounds like you trapped a squirrel with a hammer in it.

The oil is clear, so have another miller.
 

·
Premium Member
Joined
·
3,519 Posts
Discussion Starter #5
thanx man. I'm sucking one down as we speak.. alhtough I don't think its a miller. Some chek beer. Crazy, not as good as german beer.

K
 

·
Registered
Joined
·
1,527 Posts
Don't worry 'til you start seeing copper flakes and the oil pressure drops. Unitl then, keep your foot in it and enjoy.

Larry
 

·
brains
Joined
·
1,009 Posts
Dont worry the worse it can be is your mains, rods, and crank going bad, or broken rings scoring all your cylinders... Just kidding with ya, Although I cant really make out those photos too well, It's probably just from breaking in the rings.

Ben
 

·
The Smell of Nitro in the morn
Joined
·
2,411 Posts
I did not see the blue silicone in the first pics that were emailed to me. Have to take a little better pics, some were blurred.
That is using the wrong sealer and toooo much, it can get into the oiling system. It can plug a feeder/return hole before it gets down to the filter. When using a sealer do not put any on the first few threads or on the bottom of the bolt as it will come off eventually and get caught in something, hopefully the filter.
Teflon tape must be trimmed off below the starting threads.
Same with brainsboy, its the particles from break-in and other junk not cleaned before install.
Silicone could have been from the intake install change.
Even on the cleanest of motors I put together on the dragster, after warm-up and pull the filter screen, small particles are still found when assembled in a clean room.
Ever look at a filter on the first time after cam break-in ?
The screens on top of the filter help show the particles without cutting the filter in half.
 

·
Registered
Joined
·
159 Posts
There's a few sparkly bits in ya pics but ya filters caught them,, if you see them next oil change then worry,,,

But keep your ear out for unusual noises and oil pressure,,.
 
1 - 9 of 9 Posts
Top