Hot Rod Forum banner
1 - 4 of 4 Posts

·
two cups of tea
Joined
·
1,054 Posts
Discussion Starter · #1 ·
Ok so I (as most of you know seeings I post so much)have an 83 monte carlo with a small block its pretty fast,dished&forged pistons,heads,cam,headers,duals a lot more in the engine etc etc.BUT! Its kind of sluggish out the door I mean once I get to rolling I'm flying its just getting there.Whatshould I do?a shift kit?change the gears?put on a electric water pump&fan?idk,its not a posi by the way/the engine is a low compression 8.5 to 1 it was for the blower but we took the blower off it was 435 hp before so about 350 now,my grandas friend just told me lastnite that were gonna build another engine for it later on&I didn't want to ask him about this issue because,this engine is not his favorite thing(long story)well thanx guys
 

·
Registered
Joined
·
329 Posts
Gears and posi for sure maybe some long tube headers with a free flowing muffler also check your dizzy make sure it not binding also do you have the right carb for your set up sometimes people just put together a engine but they don't get all the right parts like for your heads and so on. Now im not saying you did that but it's just my two cents and I hope it helps you out.
Good luck! RJ :)
 

·
Registered
Joined
·
7 Posts
You didn't mention the txmsn and especially the Torque Converter. The correct torque converter/stall speed will do wonders in getting you off the line. After that I'd take a good look at rear end ratio and tire size.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top