Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
It's a 92 mustang lx. 4777 650 double pump carb. 3500 stall. 35 squirters. 28" tires. 499-510 lift cam with 221-225 duration. aluminum heads.

I can't figure it out! I have had the car this way for about two years now and it started happening about a month ago. I checked all the plugs. Checked the timing-35 total. At idle the vacume advance brings it up to 32 from 22 initial timing. The plugs don't look bad, I don't know why it has started doing this all of a sudden. It starts doing it at about 3500 rpm. The jetting in the carb is 72 primary and 77 secondary with a 5.5 power valve.

Any help would be much appreciated.
Thanks,
Dave
 

·
http://www.warsprints.com
Joined
·
2,024 Posts
davep228 said:
It's a 92 mustang lx. 4777 650 double pump carb. 3500 stall. 35 squirters. 28" tires. 499-510 lift cam with 221-225 duration. aluminum heads.

I can't figure it out! I have had the car this way for about two years now and it started happening about a month ago. I checked all the plugs. Checked the timing-35 total. At idle the vacume advance brings it up to 32 from 22 initial timing. The plugs don't look bad, I don't know why it has started doing this all of a sudden. It starts doing it at about 3500 rpm. The jetting in the carb is 72 primary and 77 secondary with a 5.5 power valve.

Any help would be much appreciated.
Thanks,
Dave
Replace the fuel filter & check the fuel pressure.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top