Hot Rod Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys, I have a 1968 chevy with a 76 small block 400 board 20 over. I am running a Engine Pro CamShaft Valve Lift is Int.488 Exh. 509 with a .050 duration. As of right now I have Edelbrock 750. with an edelbrok intake. I am having problems with keeping my engine running when I put it in Drive. My RPMs are set at 1200 idle, but when I put it into drive it drops down past 300rms if not lower, and bogs down and dies. Should I drop my carb size any? Or does anyone have any other suggestions to try?
 

·
Registered
Joined
·
12,338 Posts
carb size is fine.
what is your static timing set at,,
Is this a new carb,,,,
Is the engine new,,, and anything else to work with?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Im not for sure what you mean on static timing, I set it TDC. Carb is old, just rebuilt motor and trying to get it running, its flooding out real bad! What other information would you need to help me.
 

·
Registered
Joined
·
12,338 Posts
when you set the timing with the vacuum hose disconnected,how many ºs did you advance the timing from zero?Was the carb working before? Do you have a quality ignition system? Is the camshaft long duration? Are you using headers?
NOTE: you may need new plugs
 

·
Registered
Joined
·
9,050 Posts
Low manifold vac. at idle from duration of cam. Improper carb setup. The throttle plates are open too far for idle circuit function.
 

·
Banned
Joined
·
9,993 Posts
No offense but it sounds like you know just enough to really screw things up. I would either find a good mechanic that will fix your mess, or drop in a stock 350 that is in good running condition.

If you do want to fix this yourself I'm guessing it will take a greenhorn like you the better part of a week and you may spend a grand by the time your done.

Best of luck, if you're still wanting to learn what to do google is your friend but just learning what to do can take a person a while. A mechanic may get it fixed for less than a grand out the door. But it soy rs like your ignition is way off, fuel pressure may be out of line, prob needs a higher stall with that cam, and only God knows what else.
 
1 - 9 of 9 Posts
Top