Hot Rod Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello folks. Im building a 72 Camaro, or is built a little. I did a 350 to 383, set of 68-72 76cc heads with 1.94/1.50 stainless valves, 1.5 roller rockers, .550lift springs, howards rattler cam .480/.289-1800-5600 hyd flat tap, long tube headers, cheap 500cfm holley. Question is, what is killing it so bad. has 2500 stall, 350 trans, 4.10 gear. 0-300ft is all itll pull. itll turn 5k with a blink of a eye. Oh, did the eagle stroker kit from summit, any suggestions?
 

·
Registered
1979 Chevrolet Malibu 496-TH400-9" (cruiser). 1992 Chevrolet S10 355-700r4-7.625" (daily driver).
Joined
·
252 Posts
Welcome aboard!

I would have a look at the fuel management system. A weak pump or a blocked fuel filter can give you trouble with a WOT blast. Have you, or can you, measured your fuel pressure? What kind of fuel pump and/or regulator do you have? For example, having an electric pump mounted incorrectly can cause trouble. Air cleaner is clean and large enough? Sometimes folks run into hood clearance issues and put something too small on the engine. What is happening when the problem occurs? Are you high RPM in first gear or does it shift to second gear before you have trouble??

There are countless causes for a symptom like this one. We could go on for pages discussing the possibilities. This is just a place to start trouble shooting.

A larger carburetor would benefit your combination when budget/time allows.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top