Hot Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
I have a 2000 Chevy Caviliar with a 2.2 engine. I have replaced the fuel pump twice so far. It will start a couple of times then nothing. It will turn over with no problem, have spark but no fuel. I have tried hitting the gas tank and that worked twice on the first pump, nothing with the second pump. Now at a loss on what the problem could be. Any ideas :confused: ? This is the wife's driver.

Thanks Art
 

·
Registered
Joined
·
7,345 Posts
Doc here, :pimp:

Check your ground wire at the tank / Pump grounding lug.

Pull the power wire from the pump and turn the key on, measure it for power , if dead check the 20 amp fuse..

If still dead, check the fuel pump relay.



If no power check the relay socket for power and ground.

IF all that checks out, pull the codes for the computer, a code in the PCM is hanging it up..OR you could try, pull either battery cable, and hold it to the other for about 1 minute..this sometimes clears all the codes.

Doc :pimp:
 

·
Registered
Joined
·
51 Posts
Discussion Starter #3
Thanks Doc. I have tried all of that and it still will not work. Might have to take some gas to the entire car.
 

·
Registered
Joined
·
77 Posts
first off turn the key off( for 10 seconds) then on and listen for a click of the fuel pump relay and 2 seconds later a click again. That tells you the computer is up and the relay is trying to do its job. If thats the case I would make sure its getting to the outside of the pump harness. That said I would look close at the connectors at the tank end all the ones involved including the ones in the tank. The female ends can expand causing problems.Sometimes the amperage draw from the failed pump can overheat the terminals and damage them and give you problems even with a new pump.
 

·
Registered
Joined
·
1,205 Posts
Any lights on on the dash? Such as the security light (may be flashing).

Have you checked for 12 volts at the fuel pump harness (at the pump)?

You say it has spark? Yes

Will it run if you supply an outside source of fuel (carb cleaner through the throttle body)?

Let us know these answers and I'm sure we can get this thing running again.

What type or brand of fuel pump did you install?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #6
Well I took it to a different mechanic yesterday and he had it fixed within a half hour. It tuned out to be one of the wire connectors that runs under the door sill, that was supposed to been fixed by the first one. Now it looks like it is time to go to small claims court to get some of my money back :boxing: . Thanks to all with your help.

Art :welcome:
 
1 - 6 of 6 Posts
Top