Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
so my nova was running perfect for the last week or so and i didnt run it for a day. now im getting almost 0 oil pressure, it wont even idle and ill get 25psi when i rev to about 3000....it has the correct amount in it and ive never had any problems like this before....im just wondering why it happened all at once and not a steady decrease in pressure and some possibilities on how to fix it. thanks.
 

·
Registered
Joined
·
698 Posts
I saw some of your earlier posts about carb problems. Could a bunch of fuel drained into the oil and diluted it? I doubt it, but a quick ckeck would be to smell the dipstick.
What kind of filter do you use. Heard about certain brands colapsing and causing a restriction.
I'd check the engine, gauge, and sending unit grounds first. Unplug the sending unit and see if what the gauge does. Short the sending unit wire to ground and see if the gauge pegs one way or other. If it does that should eliminate a defective gauge IMO. In that case you may want to swap the sending unit.
Could the oil pump pick-up have fallen off?
Could the oil pump be defective(stuck bypass valve, cover loose)?
Could be the sign of a spun bearing. I wouldn't be reving it until you find out what the problem is.
FWIW
ssmonty
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
i live on a marine corps base and havent made any enemies so i doubt someone sabotaged it...and i havent changed the filter in quite some time it was a moblie 1 extended performance filter and i finally got it off a few minutes ago because it had been stuck...it was full of sludge and garbage so im hoping it was that. it just happened this morning though which was strange because i always check my guages when im driving and there were no problems. it was just real hard to start this morning and it sounded rough when it finally turned over....and when i shut it off i got that metallic ticking sound as well...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top