Hot Rod Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey guys im looking for some info on these procomp products

heres the rods
Procomp Electronics 41253 Procomp 4340 ''H'' Beam Connecting Rods

and heres the crank
Procomp Electronics 4019 Procomp 4340 Steel Crankshafts

id like to build a 496 over the winter and wanted to know if anyones built one with these pieces since theyre so much cheaper than say eagle or scat, this engines not gonna be anything ridiculous just a 10-1 pump gas hydraulic roller thats gonna fall off around 6000 going in an 85 k20 with one ton running gear
 

·
Registered
Joined
·
12,338 Posts
If you plan to race 4x4 then dont buy bargain basement parts.Build the engine to last.Im not saying dont buy pro comp,Im saying dont cheap out on a severe duty engine
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
no racing maybe stop light to stop light from time to time when im next to some punk highschooler with a spoiler and a fart can, mostly weekend cruising and the occasional truck pull
 

·
Registered
Joined
·
9,050 Posts
Ok here goes.

Last year, even with Michigans terrible economy, I built three 496 BBC's based on ProComp components.

Rods, I bought several sets of H-beam stock length and +.250" length from their "Overstock" clearance section. All were right on spec as far as size and length. Finish is not as polished as more expensive sets. Some very minor swirl machine marks visable.
otherwise the cores look like everyone else.

Cranks, also from their "Overstock" 1 forged steel and 4 cast steel. The forged crank was almost identical to the Elgin forgings that I sometimes buy. Specs were just a bit fat on the rods. I usually polish my own crankshafts before assembly, so there was no problem. Cast cranks were within spec and not bad looking. Again, well finished, not polished on outer counterweight edges, but passable..
like a factory GM piece.

These engines were all built with 10.2-1 compression. Two with KB hypers and one with Probe forgings to go with the forged crank.

All three balanced up with no problems or Mallory metal.

No unusual extra block clearancing. Just minor grinding in the normal couple of spots on the block.

One engine, the forged one, went into a street racer from SE Michigan area. He loves it. Second one went into a street rod. Owner complains of too much power?? and the other cast piston/crank engine is going into a 79 El Camino that used to be mine.. Present owner has had money problems and the engine is still waiting for install..

So there is my experience with their cranks and rods..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
thanks again bob, its funny since i was more than likely going to get a set of probe pistons to go along with the budget theme i have a set of 990s that ive already rebuilt and my top end will be a edelbrock rpm airgap and a holley 850 dp probably going with a mild marine grind from comp so i can get a flatter torque curve already have the top end just have to buy the pistons and crank since i found the rods on craigslist back in january, if you have a suggestion on what cam i should run im all ears
 

·
Registered
Joined
·
9,050 Posts
I have been using Howards cams. between .660 and .685" lifts. Very easy on parts. Rev like a small block in mid range. Also Lunati makes a .685" marine cam that is killer in a hot street/race motor.

call 559 275 2001 for best prices on those Probe pistons ask for allen.
 

·
Registered
Joined
·
9,050 Posts
Hust an add on about Pro Comps stuff..

In August I built a big cube Mopar. 4.250" stroker. I had the owner buy a Pro Comp electronic distrib.. I've been selling them for chebbies for years and as luck would have it the Mopar one didn't work, out of the box. No problem return. Then the customer bought a Summit electronic distrib. It wouldn't fit the engine with aftermkt aluminum heads. Had to mill a relief in the head.. Only to find it dead right out of the box. Returned it and went to a new MSD unit.. IT WORKED ! .............. But died one week later...... Another new MSD unit was installed..... It worked for two weeks than started firing at random intervals and making for some real interesting idle problems and exhaust noises... Another new MSD unit was installed and it worked six days and the vac advance died!

Meanwhile the customer is HOT! and very wary of any electronic distribs.. Tired of returning on a tow truck. Also he has been put on Summits BAD list for returns. For these and other returned items that were supposed to fit Mopar and don't, or died within a month of very limited use... Name brand stuff too
 
1 - 8 of 8 Posts
Top