Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
702 Posts
Discussion Starter · #1 ·
I installed the Q-jet on my truck and it idles fine. I took it for a long drive this morning and it had no power. It even stepped down going up a slight grade. I had the pedal to the floor on some other easy grades. On the trip home I noticed a slight back fire after I let off the gas. It would pop once and that was it. I haven't checked for a warped manifold yet but I am pulling 20" of vacuum. The Q-jet is a Jet Stage 2. See my earlier posts.

With 20" of vacuum could I still have a vacuum leak at the manifold gasket?
 

·
Not Considered a Senior Member
Joined
·
10,722 Posts
You sure could, mine did. Mine pulled a perfect, needle not moving 20 inches of vacuum and the intake was leaking like he**. The secondary side maybe too lean, this is a easy fix as all you do is remove the secondary needles and replace them with richer ones. Or the fuel filter needs replaced, or it`s running out of gas.
 

·
Registered
Joined
·
702 Posts
Discussion Starter · #3 ·
I pulled the carb to see if it had oil in the plenum but it was clean with no gas or oil. I last drove it Sunday afternoon. I retightened the intake manifold bolts without a torque wrench and was able to tighten them at least 1/4 turn. I checked the new spark plugs and they are brown on the tips and some light tan at the base of the electrode and brown around the insulator. These are new v groove plugs.

I got in and tried to take off and it stumbled very badly. I gave it some more gas and it acted like it died. Pumped the gas and it would finally kick in until I floored it again and then it would act like it was dead. It was hard shifting even more than normal. Vacuum is at 18. It goes to almost zero when I give it gas. Does this sound like a big vacuum leak? I believe I have checked everything and can't find a leak. I still get the pop when I let off the gas.

I think I might try switching carbs to one I know runs good and see what happens.

BTW I have a 1" phenolic spacer on it if that has any bearing.
 

·
Registered
Joined
·
702 Posts
Discussion Starter · #4 ·
There seems to be a problem with the Jet carb. I switched to another Q-jet I put on my Catalina that seemed to run fine and the truck runs much better without even fine tuning it. I checked the secondary shaft and it seems to be loose. The secondary rods where stuck when I bought it so they may have been bent. I have plenty of them I can swap from other Q-jets. I am much happier with the performance but believe I am still not there. Gas mileage still seems to be good.
 

·
Registered
Joined
·
66 Posts
Mertz said:
There seems to be a problem with the Jet carb. I switched to another Q-jet I put on my Catalina that seemed to run fine and the truck runs much better without even fine tuning it. I checked the secondary shaft and it seems to be loose. The secondary rods where stuck when I bought it so they may have been bent. I have plenty of them I can swap from other Q-jets. I am much happier with the performance but believe I am still not there. Gas mileage still seems to be good.
You need the book on QJets by Cliff Ruggles. You will be very glad you got it.
Summit has them.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top