Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter · #1 ·
I have rebuilt several of these and usually have good results. I take my time and check everything. The one I just built came out of a 93 Z71. It had the 3-4 clutch burnt up in it. This trans had been gone through before about 10 years ago the owner told me. I found a few shady things on tear down, missing screens, wiring harness clips broke, and the main plug silliconed into the case.

I did a lot of upgrades to this trans because the owner pulls a heavy trailor,

8 Clutches in 3-4
Sonnax Heavy pump slide spring
Sonnax .490 boost valve
Sonnax super hold 4th servo
New transgo sep plate
Plastic check balls
Sonnax pinless 1-2 3-4 and froward pistons
Beast shell
29 elemet double cage sprag
Sonnax check ball capsule for 2-3 shift
Had the pump resurfaced
New seal kit
New wiring harness
New converter

All the clutches besides the 3-4 were in good shape so I left them in. The only thing I did that I normally do not do is used the angle cut teflon seals (700R4) style on the pump stator that seats in the reverse input drum. I also used cut seals on the input shat. But, they are a newer style that have a notch interlocking type cut.

Anyway the trans seems to slip intermintent in reverse. It does drive forward but does not shift into 3rd. I can brake tourqe it in OD and it will chirp the rear tires. Sometimes it will brake tourqe in reverse. I put a pressure gauge on it and it showes about 65-70 psi at idle. It does not raise much if any in reverse. In OD it will jump way up to 200 or more if I brake tourqe it. The other wierd thing is in park it acts like its in gear, the engine will not rev like its in P or N. I have never seen one do this, I checked the linkage under the truck and its right.

I air checked all the clutches when I put it together and everyting seemed fine. I know the low reverse clutch is holding good because with a rubber tiped nozel it checks good, turns on and stay on until I remove the nozel. I am thinking a problem in the reverse input drum, cut lip seal during instal or the angle cut stator shaft seals to the reverse input drum. Any other ideas?
 

·
Registered
Joined
·
158 Posts
Discussion Starter · #2 ·
3-2 downshift solenoid clip was gone, solenoid popped out of the valve body. I bought the valve body from a local trans supply shop. It was a "known good used" part. It had all the solenoids on it. I figured they had tested everything so I stuck my new Sonnax parts in and stuck it on the trans. Never even thought to check for clips missing.

I had my mind set on it being the Teflon rings so I pulled the trans without removing the pan, and tore the trans down. I was inspecting the valve body and the 3-2 downshift solenoid fell out. The forward clutch got just a little toasty so I replaced it. I also used the solid rings on the pump and input shaft, then resized them.

Just drove it about an hour ago, she drives and shifts really nice..:D
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top