Hot Rod Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
88 thunderbird 5.0

heres the problem. turn the car on, brake lights go on as if the lights were on, but the front lights dont go on when i turn the lights on. in the dash, the high beam and left blinker stay lit up, but the lights arent blinking. blinkers dont work, couldnt get the right front headlights to light up no matter how hard i tried. when i pull back on the brights, theres a buzzing noise that doesnt stop until i pull off the brights(which still dont light up). when the car is off and keys are out, the rear lights are still on as if the lights are on

ive gone through fuses... but thats about it. thought i could use some of of ur ingenious advice!
 

·
Just one of the guys
Joined
·
3,074 Posts
Sounds like some major problems!!! You state that the brake lights come on when you turn the car on but when you turn it off they stay on.
when the car is off and keys are out, the rear lights are still on as if the lights are on
I'm not quite sure what you are saying. And if they stay on how do you get them to go off so they come back on when you turn the car on. Has the car been in a wreck? Have you done anything different to the car, that this started happening or did it just start doing it out of the blue. Electrical can be hard to diagnose, especially without seeing first hand what is is doing exactly. So a little more info is going to be needed. For one it sounds like the brake light switch may be bad. This is located on the column and when th ebrake pedal is depressed it brakes contact with the switch and lets the brake lights come on. That would let the lights remain on. I'm not that familiar with Fords but there may be a headlight relay somewhere that could have went bad allowing the headlights not to come on. Also have you done anything to where there may have been a power surge or shorted something out as in hooking up jumpers wrong or splicing in some wires? If you can, tell us how and when it started doing it and anything else you may have done out of the ordinary.

I did find
THIS ARTICLE
 

·
Registered
Joined
·
9,050 Posts
Bad headlight switch or brake light switch or ground or combo of them.

I just did an 86 Ford F250 diesel truck that the glow plug solenoid had failed on. Some genious decided to "Jump" the solenoid and in the process fried the main wire running thru the harness. This of course melted several wires together and all kinds of strange things would happen when the battery was hooked up. Except start the engine.

Complete re-wire from fuse box to engine compartment. Including wiper, heater and ign switches.
 

·
Administrator
Joined
·
18,433 Posts
As I always say in these cases, make sure you have good grounds first.

This does seem to be more than that, but it doesn't hurt. My guess would also be the light switch.
If the brake lights (not parking lights?) are coming on, also check your brake light switch.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #5 (Edited)
it just started out of nowhere.. the brake lights arent on, the taillights are just lit up as if the lights were turned on. this started christmas day (when i recieved it with the paintjob by my bro and dad)

by the way, the driver side headlights dont work, just the outer markers
 

·
Just one of the guys
Joined
·
3,074 Posts
When the car was painted were the lights taken out? It sounds to me like you have pinched a wire somewhere and have a short.
 

·
Registered
Joined
·
4,104 Posts
you do have a mess

my solution to find the bunch of problems

go to a u-pull it yard and get a complete "everything" harnesses/switches/lamps and swap all before you put power on anything

you have to many overlapping faults to try to do it one at a time
 

·
Registered
Joined
·
112 Posts
Discussion Starter #8
oh yea.. the lights were definitely taken out.premium paintjob = ripped apart.

ahh i hope i can get this problem figured soon. i have no bucks at all... no job! thanks for the help guys im definitely another step forward on this problem.
 

·
Now if I could just afford Gas
Joined
·
75 Posts
I had almost the same problem on my truck and it turned out to be the wire harness that connected to my trailer brake light system.
 
1 - 9 of 9 Posts
Top