Hot Rod Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I recently purchased a 1990 Camaro with a 383 bound to a 700-R4 transmission I was told it had a 2500 stall. As I drove, it seemed that it did have one. It would rev, catch, and go. My dad followed me home the nice 5 hour drive we had so I did nothing stupid just drove. About an hour away from home I smashed the peddle just to see yah cause this thing sounded mean as hell with a brand new just broke In 383 with close to 400 horse I just had to lol. I smash the peddle…NOTHING it didn’t kick down at all it stayed in same gear so I put it in second gear and floored it. Holy hell I lost my stomach lol I was like…nice. I get home my grandma wants a ride she gets in I was like a 2500 stall I bet I could burn em like no other. I stop, put it in First gear, press the brake, floor it nothing im like wow now I look like an idiot…So I just decided screw it I’ll just take off. Well I wanted to cry I let off brake and I think I could of ran faster than it for the first 3 seconds I mean it was like I was on an electrical scooter and im not even kidding. Then after about 2500 rpms it took off like expected. So im wandering COULD there be something wrong with the converter keeping it from locking properly or does it have a 2500-6000 cam without a 2500 stall converter? The guy did not lie once so im hoping it does have one with just an easy fix or a cheap one. So if you have any ideas or anything I would really appreciate them. I was so satisfied until this happened and it really makes me mad so please advise me if you can thanks.
 

·
http://www.warsprints.com
Joined
·
2,024 Posts
Goany said:
I recently purchased a 1990 Camaro with a 383 bound to a 700-R4 transmission I was told it had a 2500 stall. As I drove, it seemed that it did have one. It would rev, catch, and go. My dad followed me home the nice 5 hour drive we had so I did nothing stupid just drove. About an hour away from home I smashed the peddle just to see yah cause this thing sounded mean as hell with a brand new just broke In 383 with close to 400 horse I just had to lol. I smash the peddle…NOTHING it didn’t kick down at all it stayed in same gear so I put it in second gear and floored it. Holy hell I lost my stomach lol I was like…nice. I get home my grandma wants a ride she gets in I was like a 2500 stall I bet I could burn em like no other. I stop, put it in First gear, press the brake, floor it nothing im like wow now I look like an idiot…So I just decided screw it I’ll just take off. Well I wanted to cry I let off brake and I think I could of ran faster than it for the first 3 seconds I mean it was like I was on an electrical scooter and im not even kidding. Then after about 2500 rpms it took off like expected. So im wandering COULD there be something wrong with the converter keeping it from locking properly or does it have a 2500-6000 cam without a 2500 stall converter? The guy did not lie once so im hoping it does have one with just an easy fix or a cheap one. So if you have any ideas or anything I would really appreciate them. I was so satisfied until this happened and it really makes me mad so please advise me if you can thanks.
When you say "rev, catch & go", what does that mean? Is it acting like the tranny is slipping? If it has a manual valve body in the tranny, it won't downshift on it's own, you have to shift up & down manually. If it don't have a manual valve body, there is possibly something out of adjustment with the kickdown cable. Now here is a thought also. If it has a reverse manual valve body in the tranny, what you think is first gear (all the way back) is actually 3rd gear and 1st is the (D) position.
 

·
Registered
Joined
·
36 Posts
Are you sure the carb is opening to full throttle? Just because the pedal goes to the floor doesn't mean the throttle plates are opening all the way.How about the timing? Is it set with a timing light? Sometimes we look for the hardest things first, so kick back and think of all the easy fixes first! :D .I'm not trying to demean you, I have been in the same situations before,...Keep us posted......CR
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Ok so problem is jerk before purchased a manual carburator and took back flap off it was flooding motor switched it out no problem thanks guys learned a lot from your posts
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Just to let you all know a little more about the car lol since i kinda let you all out. 383 Stroker 412 horsepower 700R4 Beefed up with wider bands and all the works sadly bolted to 2.29 rear end gears nice paint nice body ready to go blu8e with silver stripes and a 2 or 3 inch cowl hood ill get pics up one day. Oh and oil is fine just running some break in oil engine has 300 miles on it tranny has 700 rearend has same as engine.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top