Hot Rod Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all! Needing some help as I’m about to drop the truck off at the speed shop! Here’s the low-down:

On cold start up, the electric choke and high idle work to about 1,000rpm. 700 rpm off cold idle. Hitting the throttle in neutral revs right up cold and hot running temp, no issues. As soon as it’s loaded/moving, when the throttle is cracked >40% it falls on its face. If I ease into the throttle until RPMs slightly rise then hit WOT, then the thing screams/kicks ass. Any ideas are appreciated!

-new crate engine; Chevy 350 stock cam
-new Edelbrock 1406 600cfm
-3,100 ft elevation
-new Edelbrock air gap intake manifold
-new patriot headers
-new HEI distributor
-new wires and plugs
-floats set to 7/16”
-initial timing set between 6-14° with no where correcting issue
-idle vacuum at 16”Hg
- valves adjusted to 3/8 tight past 0 lash
-7547 metering rods
-0.095 jet in primary
-0.092 jet in secondary
-uncoated rod springs
-mechanical fuel pump
-accelerator pump size is factory/unknown and tried on all 3 linkage setting with no difference
 

·
Administrator
Joined
·
9,861 Posts
Moving to Engine forum
 

·
Registered
Joined
·
13,919 Posts
Idle vacuum is low which might be altitude but certainly requires knowing about what cam is in there.

The jetting appears off with the primary too rich and the secondary too lean.

The idle speed is high which can be a bigger than stock cam, this along with low idle vacuum may indicate that there is too much curb idle throttle opening that will expose too much transition slot which results in an off idle to main metering stumble.

I live on the west coast but travel into the mountains frequently and do not find a need to tinker with my AVS carb settings nor the ignition when crossing the passes at 3000 to 4000 feet nor driving inland on the plateau of about 3000 feet. My 350 with LT4HOT cam takes the altitude changes in stride without apparent issue.

Bogie
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Idle vacuum is low which might be altitude but certainly requires knowing about what cam is in there.

The jetting appears off with the primary too rich and the secondary too lean.

The idle speed is high which can be a bigger than stock cam, this along with low idle vacuum may indicate that there is too much curb idle throttle opening that will expose too much transition slot which results in an off idle to main metering stumble.

I live on the west coast but travel into the mountains frequently and do not find a need to tinker with my AVS carb settings nor the ignition when crossing the passes at 3000 to 4000 feet nor driving inland on the plateau of about 3000 feet. My 350 with LT4HOT cam takes the altitude changes in stride without apparent issue.

Bogie
Thanks! I’ll adjust some things to give it a try!
 

·
Registered
Joined
·
5,548 Posts
The air gap intake could be part of the problem.
And fuel pressure too high.

Where do you live?
Ambient temps can be a factor too.
 
1 - 7 of 7 Posts
Top