Hot Rod Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
i got a blazer and the starter messed up. i put a new starter on and there is no power so i put a jumper cable to the pos. post on the starter and i got power but it would not turn over fast enough?????? :smash: :drunk:
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
starter

the starter was starting to just whine and then grab every once and awhile. it was grounded good before but then i shut the truck off and went to start it back and there was no power.and the battery is brand new. when i put the pos. cable to the starter it had power but not enough to turn over it just clicked??please help me!!!thank you :smash:
 

·
Sophisticated Minimalist
Joined
·
120 Posts
ajh86 said:
the starter was starting to just whine and then grab every once and awhile. it was grounded good before but then i shut the truck off and went to start it back and there was no power.and the battery is brand new. when i put the pos. cable to the starter it had power but not enough to turn over it just clicked??please help me!!!thank you :smash:
just so you know, just because a battery is "brand new" does not necessarily mean that it is a good battery...not saying that's problem, just letting you in on that little piece of info...if you have a volt meter then that can help you track down your problem as long as it's in the electrical system...if it's not, then I suggest you take your starter to an auto-electric shop if you have one nearby or some shop where they can test and rebuild your starter if necessary...could need a new solenoid or a new drive...thats my recommendation...good luck
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top