Hot Rod Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Not going in gear after thinking it’s the pump . It was the converter. (2700-3000 stall)Got it to pump and now not going into gear at all.. please help
I think I have tried everything I know
 

·
True Hotrodder
Joined
·
1,725 Posts
More information would help here. Is this a recent rebuild? Professional or other? Did the convertor fail or was it not installed correctly? What about fluid levels? And are you speaking of mechanically not going into gear or you are moving the shifter arm through the gear range (drive wheels in the air and chassis supported) and not getting any rotation from the output shaft?
 

·
Burnt out transmission tech.
Joined
·
984 Posts
Not going in gear after thinking it’s the pump . It was the converter. (2700-3000 stall)Got it to pump and now not going into gear at all.. please help
I think I have tried everything I know
Got it tp pump? Explain that please.
 

·
Hates: Liver. Loves: Diesel
Joined
·
5,939 Posts
Sounds like TC not installed correctly, he ran it, then properly installed the TC and discovered that the pump is destroyed. That's my guess.
 

·
True Hotrodder
Joined
·
1,725 Posts
Might be he busted the gearset, if he hasn't run it too much like that he might be able salvage the pump with a new set of gears.
 

·
Registered
Joined
·
231 Posts
Running it without the pump functioning will destroy it in a hurry. Like flat towing it without removing the driveshaft.
 
1 - 6 of 6 Posts
Top