Hot Rod Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
N someone give me an idea if i need new tranny ... Th350 .. Reverse works fine but when i put into any forward gear it acts like its in neutral ... I have checked fluid (fine) ... I noticed that vac line from carb was flattening out when engine running ,,, changed line ,, no avail .. Could it be bad modulator? Someone also told me filter .. Wouldnt those affect reverse as well ... Help please
 

·
Administrator
Joined
·
10,187 Posts
you are correct. If reverse works fine, that indicates there is enough main line pressure to operate the trans. Reverse operation also indicates the engine power is transmitted to the trans via converter and input shaft

IF the trans will not move forward in 'any' forward gear including manual 1 . The forward clutch pack is not operating for some reason.

Is this an old trans or fresh or junk yard unit?
 

·
Registered
Joined
·
95 Posts
Does you shift cable have alot of play to it? I had one where the rooster cone nut came loose on the inside and I couldnt hit P/R. I had N/D but because it got so loose it would not move to P. I swore my tranny was shot until I got a little advice from here. 11/16 wrench and about 10 mins of time. Plus if you drop the pan, install a drain plug so you never have to worry about juggling all that tranny fluid in a pan. Just something to check into.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top