Hot Rod Forum banner

1 - 6 of 6 Posts

·
Hotrodders.com Moderator
Joined
·
2,783 Posts
Discussion Starter #1
Truck is a 88 5.7 "K" engine 4X4

I am having problems with hard starts after the engine is warm and the truck sits for say 20/30 minutes. Then when it does fire it runs real rough like it's flodded out. It will clear up if you clean it out. Also the thing will hunt or surge at idle when warm. It does not run 100 percent anytime right now.


I have done the basic's so far. Make sure the plugs/wires cap/rotor are in good shape. The timing is set and working proper. I know the engine is healthy because it only has 15,000 miles since i rebuilt it. I also installed a new fuel pressure regulator, I only got 1 code and that was 2 nights ago and it was a 44, (o2 sensor went lean)

Now some questions. I want to check the fuel pressure next, but as you all know there is no port to do that, so what typ of fittings have you made/ bought to check fuel pressure??? What is the correct pressure???? Any other ideas about what to check??

Keith
 

·
Time is short, are you ready?
Joined
·
655 Posts
Keith,
Check the hose going to your MAP sensor. My original hose was a section of hard plastic with rubber fittings on the end. A small crack will throw it off since it will be sucking air. Also, have you verified your TPS voltage? I just had a TPS sensor go bad on my TPI and it really messes things up when it is an intermittent problem (i.e. fluctuating voltage). A bad TPS like I had will not always throw a code.

As far as the fuel pressure, there is an adapter you can get. Pretty pricey, so take a look and maybe you can devise something homemade.
http://www.cfm-tech.com/catalog/fuel_-_cfm-tech_fuel_psi_adapter_2940807.htm



Good luck my friend.

Ed
 

·
Registered
Joined
·
4,104 Posts
keith,
the Autozone.com site has a "troubleshooting" section on the main page that can be a help because it gives a most common to least common priority list based on at least a few of the problem specifics (ex: hard start, choose cold or hot start)

just reading the list (20+causes?) for a given problem might "make a light bulb turn on" in your head....for me that translates to "whoops" I forgot (CRS!) to do something.....
 

·
Hotrodders.com Moderator
Joined
·
2,783 Posts
Discussion Starter #4
miss

Ed,it's funny you should mention the TPS...I have been having the mechanics intuition thats the problem.....But since i had no code i kind of droped it..

If i did a bunch of this stuff i would invest in the gauge,,,but i think i'll modify something in line to check the pressure. Do you know what the fuel pressure should be??


Keith
 

·
Registered
Joined
·
16 Posts
88 tbi

have same truck and same problem,is engine stock or modified.i would definately start w/ fuel pressure,stock is 9-13 modified is 13.75-14 .i got tbi fuel gauge from summit,it installs at fuel filter
 
1 - 6 of 6 Posts
Top