Hot Rod Forum banner

1 - 2 of 2 Posts

1 Posts
Discussion Starter #1
I'm new here and hope you all can help. I hardly know much about stuff but I do try.

My problem is a few days ago I attempted to install a B&M shift kit in my 72 skylark with a 350 and th350 tranny. After following the instructions and getting everything back together, it would bearly go. I checked the fluid level and it was a low so I filled it up, after that it took off for about 30 feet, then just quit going. Reverse worked fine. I rechecked everything and still no go. I reinstalled the original seperator plate and check balls.,(There was one ball that was smaller than the other 3 though???) everything was the same still no drive only reverse. I was rechecking to see if there was any loose valve body bolts like the troubleshooting manual said and stripped the threads in one seperator plate hole.

Well that one is shot I figure so I take the one out of a parts car I have. Same year same engine etc. It was hit by a deer then parked by my uncle so I am pretty postive that everything was good in the tranny.

After a grueling day of installing the "new" tranny, I managed to finally get everything bolted back up. Filled er up and yup SAME exact thing, only reverse and no drive. I did not install the shift kit or anything to the new tranny. I did put in a new vacuum modulator thinking that the old one might be bad though. I have messed with the linkage outside the tranny several times and it seems to hit all the detents etc. I have tried to get it moving in D,L2 and L1 but nothing just reverse. On the bright side though my fasten seatbelt light started working which it never has before.

Does anyone have any idea what could be causing this? or did I mess up the first tranny and the 2nd one was already messed up to begin with? I've already probally lost my job over this and really need to get my car running again somehow. any help would be greatly appreciated.
1 - 2 of 2 Posts