Hot Rod Forum banner

1 - 3 of 3 Posts

·
4 chevys and a ford
Joined
·
596 Posts
Discussion Starter · #1 · (Edited)
2001 chevy express 4.3L

I have learned that this engine's ignition system is very sensitive. I have the van since 06. I have been completely through it, several times over.

I have a 301 code. I also had a 171, but found a vacuum leak at the PVC.
Repaired that, and I thought the 301 would go away. It didnt.
I am running OEM parts, and the distributer is relatively new.
Spark wire looks fine. Though some were resting on the exhaust manifold, but none of those were missing. I havnt pulled the iridium plug yet, but it is also new.

I then noticed that the coil is loose in its bracket. The bracket that is part of the coil. The coil is original. Could that be a problem? Grounding problem?

It also has the updated direct fuel injection. No poppet valves

I cant find the seal for where the brake booster line connects to the upper intake. It seems a bit loose. Any ideas?
 

·
Registered
Joined
·
3,817 Posts
I recall seeing those coils with track marks on the bracket and having misfires.
Pull the 1 plug and see if it looks lean or rich, and replace with new one.
 

·
4 chevys and a ford
Joined
·
596 Posts
Discussion Starter · #3 ·
I recall seeing those coils with track marks on the bracket and having misfires.
Pull the 1 plug and see if it looks lean or rich, and replace with new one.
Will do. As soon as the rain stops. I think im just going to get a new coil anyways. They are cheap and easy. Even the OEM one.

I have been searching everywhere for the o ring seal where the break booster line exits the upper intake. I cant find it anywhere.
 
1 - 3 of 3 Posts
Top