Hot Rod Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey Im having a problem with my vacume secondary holley carb. So the way it all started was it was running way to rich juss b4 it would compleatly lean out. problem was that the float in the front was too high, so I lowerd it to the right hight.. and then i checked the float in the back(secondarys) and It was too low, like really low.. so I raized it up. After I took it for a drive.. Ran wicked, off the primarys, then it ran even better off the secondarys.. So I jammed threw all the gears, but then when I went to slow down an pull in the clutch it wanted to stall, so i kept it running, wen back home and looked at what was goin on.. there was gas pooled up ontop of the secondarys, and leaking outa the throdle shafts.. so after kinna fiddling with it for a wile and scratching my head I took it out again w/o going to full throdle and it still leaks gas on top of the plates. It gets horable gas milege like this.. and runs like **** kuss its too rich... think its the floats in the back, or mabye somthing to do with the metering plate??
 

·
Registered
Joined
·
45 Posts
you probably need to readj. the secondary float level or the needle has junk in it. Pull the secondary needle out and check for dirt. when you put it back in 3 threads showing above the bowl is all you should need. Then try it again. If it still floods out replace the needle and seat.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
K, will doo.. Ill try that.. actualy i think thats what i did the last time this happend so thanks for reminding me..
 
1 - 3 of 3 Posts
Top