Hot Rod Forum banner

1 - 6 of 6 Posts

·
tryn to learn
Joined
·
841 Posts
Discussion Starter #1
All the lights on my 82 grand prix work awesome but the hazards, they are dull and flash inconstant. once in awhile they will get a full bright flash. i started with replacing the bulbs and that seemed to help a bit. but they still do not work good. what would be next to check? is it most likley the hazard flasher in the fuse box?

with the tail light bulbs. they have the bulb # on them, does a larger # mean brighter bulb or is there a meaning to them?

thank you
 

·
Registered
Joined
·
4,104 Posts
Post your repair/problem on a Pontiac bulletin board, maybe somebody else with a Grand Prix had the same problem.

Digital volt meters are on sale at Harbor Freight for $3.99

Diagnose and find the problem then buy parts.
 

·
Registered
Joined
·
41 Posts
spend the 2 bucks for the flasher if that dont work check you grounds you can get a piece of wire put the hazard lights on touch the wire to the side of bulb and to ground see if it works better if so go around clean up grounds
 

·
Administrator
Joined
·
18,433 Posts
It's probably the flasher. Most GM cars of those years have 2, one for the hazards and one for the signals. The one on the fuse box is the signal one, the other is tucked up under the dash, usually on a clip, near the steering column.

The lightbulbs need to be the same number as you took out....most likely an 1157
 

·
tryn to learn
Joined
·
841 Posts
Discussion Starter #6
thanks for the input everyone

i replaced the flasher and it works like new again :thumbup: even got that ticking sound back.
 
1 - 6 of 6 Posts
Top