Hot Rod Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
looking for a book on the wire diagram and a repair manual for a 63 cadillac coupe de ville. the guy who had it before me cut and spliced it so bad that i can't trace them out to replace them. also can anyone tell me where i can find a turn signal switch. thank you
 

·
Registered
Joined
·
7,345 Posts
Diagram

Doc here::pimp:

I always go to the main Library for diagrams for Vehicles I am working on.

Call your main Library, ask for the reference Desk, and ask for the GM (Not Haynes or Chilton) manual for your car. If they don't have one, sometimes they can outsource it from another system.

They usually don't lend these, so you will have to go and Copy it at the library on their machine. Still.....

It's cheaper than a Chilton or Haynes that you can obtain at the auto parts house for about $25 bucks.

As for the Turnsignal switch, try OPG for an original replacement. You might watch EBAY under Cadillac Parts sometimes the oddest things show up just when you need them! Other than that maybe try to locate an "Old School" Boneyard with a Caddie in it.

Hope It helps!

Doc :pimp:
 

·
Registered
Joined
·
82 Posts
I think I can help on this one.

In addition to what doc said, try a motors manual or mitchell manual for 1963. Library should have one in reference section.

If you cant locate one, contact me by email, I have several old manuals.

As far as the TS switch., google the part.
There is tremendous support out there for old cads. Do some price comparisions though. Some vendors think if you have a caddy, you have lots of $$$ hemmings is a good source also.
 

·
Registered
Joined
·
1 Posts
turn signal switch,63 deville

my 2000 catalog from "U.S.A. Parts Supply" lists the turn signal switch as well as several manuals. The address is 8505L Euclid Ave., Manassas, VA 20111. Phone is (703)335-1935. I have a 63 Coupe Deville I would like to sell.
 

·
Registered
Joined
·
7,345 Posts
Doc here, :pimp:

Well, In TWO years..I would hope he has fulfilled the need for a diagram..and repaired the problem.

Perhaps HE will post back and tell us if it has been resolved after 23 months..

Doc :pimp:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
no i haven't

the wireing is still a mess. i don't have brake lights, or turnsigles so
so if you have answer i would apprechate the help
thanks smokin'joe
 

·
Registered
Joined
·
7,345 Posts
Doc here, :pimp:

Check ALL your grounds at the rear harness First..

Check for power at the lamp buckets (socket pads) in each mode..If dead..

Sounds like the PLUG at the bottom of the steering column has pulled loose..or has burned or dirty contacts..Check that First, and clean and burnish the pins..

If that does not help, your Turnsignal switch is probably bad, or the harness up the column has been sliced..you will need to pull and inspect both and OHM them out for function/Continuity. (Switch to Harness to pin).

If that does not cure the problem backtrack the rear harness, inspect for cut or open wires..

Doc :pimp:
 
1 - 8 of 8 Posts
Top