Hot Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
1989 IROC-Z 350 TPI cranks, has fire and fuel pressure but will not start. I have taken the car to two different dealerships and about half a dozen recomended mom and pop shops with no luck. They have replaced every sensor and module that deals with the ignition. The ECU has been replaced 6 times with GM ECU's and the E-Prom has been replaced twice with GM E-Prom's. Every mechanic has said the ECU is giving out a weak injuector pulse but replacing the computer has never helped and neither has anything else. The car now has a 383 stroker every sensor and module inside and out is new a brand new complete wiring harness from GM new holly fuel pump new TCI trans basically redid the whole car. But it still doesn't start and it still gives out a weak injuector pulse. The only way to start the car is to spary ether in the intake but its fuel injected and thats not good. TPI's Mini ram intake with 28lb injectors. Now once I do get the car started that way I can drive around and turn the car off and restart it all day long. Once it sits over night you have to start all over. Has anyone ever heard of this problem or a fix for this problem or any suggestions at all. Please help
 

·
Hotrodders.com Moderator
Joined
·
1,642 Posts
How much fuel pressure?

Sounds to me like it's lean for some reason.

Open loop should have rich parameters for fast start up.

I'll assume you have tested the coolant temperature sensor.

This can cause a problem if it's reading high or faulty.

Another cause of a possible lean condition would be a vacuum leak of some type.

What type of ignition system does it have?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Fuel pressure is 45psi.
I have replaced the temp. sensor but it was about a year ago. I have been dealing with this problem for about 4 years. The car has been sitting at a local speed shop thats owned by a friend of mine for the past year and a half. we went through and replaced all the vacume lines. The car has a full MSD ignition. Blaster 2 coil, 6a box, Hei distributer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes I have gone through and checked some grounds but i'm not sure if I have checked or found them all. Thanks for the web link.
 
1 - 5 of 5 Posts
Top